F1 Games

R & D Wont Work?!

This topic contains 4 replies, has 4 voices, and was last updated by  BarnstableD 6 years, 6 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #128933

    Bradley Downton

    Hi all.

    I got all the way to GB in my first season and NO R & D would work at all. I re-started and have just completed the R & D in Aus. Still no upgrade:(!

    What happens is:

    I arrive at the session and realise I have a test.(I had another championship before wher i got upgrades and it all worked but now it just wont and im doing it EXACTLY the same way.) I click on the test, accept it in FP1 and drive out. Beat the lap time on the first lap and drive back to the pits. I repeat this for FP2 and FP3 and then they dissapear just as you do when you get the part. But i dont actually get it?! The only thing i can think of is that i use replays, but im sure i did this before. Has anyone else had the same problem and does anyone know how to sort it because it’s a MASSIVE disadvantage.



    Are you on Live or the PS Network? May have been covered in a bug update?


    Bradley Downton

    I have got the patch and the game is fully update. Im on PS3.



    Once you achieve the objective, exit to menu using the menus and close the game once it has saved. The only reason I can think of this is that you close the game whilst it’s saving.



    I don’t think every R&D target unlocks a new part. I think some just give general updates that you don’t actually select. I may be wrong here but I’ve done a few of these and not sometimes not noticed any new parts.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.